BCUT withdrawals and Deposits will be Disabled for Scheduled Maintenance
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 13:42 UTC
Investigating
BCUT withdrawals and deposits will be disabled for scheduled maintenance on September 4 at 12:00 PM UTC and is expected to be completed by September 5 at 6:00 PM UTC.
Posted Sep 03, 2024 - 19:24 UTC
This incident affected: Withdrawals and Deposits.